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PREFACE
Welcome
Welcome to Agile Program Execution (PE) Release 9. 

Agile PE is designed to help executives monitor program status, and program managers define programs and manage 
product lifecycle schedules. PE includes advanced cross-program resource management capabilities so you can 
balance and allocate resources at individual, program, and pool levels. Executive Dashboards and standard portfolio, 
program and user reports are provided to enable visibility and analysis across programs.

Using This Manual
This manual describes how to use PE to integrate program and product information, thus streamlining business 
processes across the product lifecycle and across a portfolio of programs. It includes the following information: 

Note We assume you are already familiar with the basic Agile concepts and features explained in the Agile 9 
Client Handbook.

Agile 9 Documentation
The Agile documentation suite includes manuals, Page Tips for the Web Client, and API reference material in PDF 
format. Viewing PDF documents requires the free Adobe Reader™ version 5.0 or greater. To download this 
program, see www.adobe.com.

To view or download these manuals, do one of the following:

❑ Click Help > Manuals in either the Agile Web Client or the Agile Java Client.

❑ Ask your Agile administrator if your network has an Agile PLM 9 Documentation folder available.

Note To read the PDF files, you must use the free Adobe Reader™ version 5.0 or later. This program can be 
downloaded from www.adobe.com.

For earlier versions of Agile PLM 9 documentation, see the Agile Customer Support Web site (www.agile.com/
support). If you need additional assistance or information, contact support@agile.com or phone (408) 284-3900.

Table 1: What’s in this manual

Chapter Description

Preface Using this manual

Chapter 1 “Introduction” Overview of Agile PE features and processes.

Chapter 2, “Installation Notes” PE-specific installation and confriguration notes

Chapter 3, “The Executive Dashboard” Using the Dashboard to view and manage programs, resources, 
finances, and issues.

Chapter 4, “Creating and Managing Programs” Creating and working with program objects such as activities and 
gates.

Chapter 5, “The Gantt Chart” Becoming familiar with the Gantt chart tools.

Appendix A, “Eigner PLM 5.1 Integration Creating and updating data on the Eigner PLM system, and using 
Eigner objects as deliverables in PE. 
v
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Readme

For late-breaking information on Agile PLM 9, click Help > Manuals in the Agile Web Client or the Agile Java Client 
and look for the product Readme file.

Developer Documentation and Samples

If you have a valid license key for Agile Integration Services, Agile SDK, or ChangeCAST, you can access developer 
documentation and sample programs from the Agile Documentation Web site and install the files to a location you 
specify.
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CHAPTER 1
Introduction

This chapter provides an overview of Agile Program Execution (PE). It contains the following sections:
❑ What’s New in This Release
❑ Program Management with Agile PE
❑ Program Management Objects
❑ Properties of PE objects

Agile Program Execution (PE) gives you powerful capabilities to define, analyze, and manage all aspects of your 
programs. You can use Agile PE to:

❑ create and manage program tasks, resources, and schedules, 

❑ make assignments, 

❑ conduct discussions, and 

❑ manage objects. 

Powerful filtering and summarizing tools enable you to find trouble spots quickly, and drill down to study the 
details. PE’s program objects provide detailed control over all aspects of program management, from high level 
overview to individual employee activities. 

You access Agile PE objects and functionality through the Agile Web Client. 

What’s New in This Release
The following sections describe the new Program Execution capabilities in Agile 9.

New in Agile 9 SP4

The Dashboard 
❑ UI changes to Discussion and Action Item. Discussion tab filter improvements with enhanced detail view and 

next/previous navigation. 

❑ Microsoft Project 2002/2003 Integration. Includes seamless publishing of project plans from Microsoft Project 
into PE, exporting from PE to Microsoft Project.

Note Maintaining Microsoft Project-specific functionality for constraint types, custom fields, and 
dependency types in a bi-directional synchronization is not supported. 

❑ Program Cost Management. Automatic labor cost calculations, roll up of all costs throughout hierarchy of a 
project. 

❑ SDK. New Program and Discussion Class Objects.
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New API calls

public ActivityVO getActivityForServer(long activityId) throws ProgramException

where located: com\agile\program\manager\ActivityMgr.java

what it does: Loads the activity object (not the entire free) from cache. If the activity is not found in both primary 
and secondary caches, it loads just that object form the database. The activity is never stored in more tha none cache; 
if the activity os loaded into promary cache and it alreadye xists in the secondary cache, it gets removed from the 
secondary cache.

public void loadActivitiesForeServer(List keys) throws CMAppException

where located: com\agile\program\manager\ActivityService.java

what it does: Called from the DashBoard Service with all the keys; the server loads all of the activities into cache.

User interface changes
❑ New option. “Make this a top level (root) activity.”

❑ Team Tab changes. New facility enables users to add team members for completed programs. The privilege 
required to add or remove resourceh or team members (formerly called “modify privilege on any attribute on 
Team tab”) is renamed to “Modify privilege on Team.Name attribute.” 

❑ Schedule Remove is renamed to Schedule Delete.

❑ Configurable Default Workflow for Activities and Gates. Enables the user to configure default workflow for 
Activities and Gates when activities and gates are created in the system.

New in Agile 9 SP1

The Dashboard 

The dashboard provides an executive view of issues such as resource utilization and costs, across multiple programs.

An executive can use the dashboard to get an overview of all programs and their status, whether On Track, Needs 
Attention or Off Track. Tabs in the dashboard provide high level views of programs, resources and financial 
information, with links to the individual programs and activities. 

Non-executive users can view the program details relevant to them in the My Activities tab. 

For details, see Chapter 2. 

Integration with the Eigner PLM 5.1 Solution

When you add objects in Eigner PLM 5.1 to Agile PE objects as deliverables, the state of the Eigner object changes, 
triggering a workflow status change in the Agile object. You can modify a deliverable by clicking it in Agile; this opens 
the Eigner object in the Eigner web client, where it can be edited. In addition, Agile programs can be transferred into 
Eigner PLM as new Eigner projects. 

For more information, see Appendix A. 

Pre-defined and Customizable Reports

SP1 added a series of new reports on program objects. For details on available reports, see “Reports” on page 4-19. 
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Introduced in the Previous Release of Agile 9

Structured Hierarchy Control 

Roles and privileges, managed by the administrator, establish access rights to PE objects and structure. Privileges 
enable you to perform such tasks as creating, sending, or reading objects. Privileges are combined with object types 
and privilege criteria to create privilege masks. Privilege masks are then combined into roles that provide a way of 
allocating a common set of privileges to a group of users who have common functions. 

Note To do anything in Program Execution, you must be assigned to at least one role. 

Resources and resource pools (which are essentially Agile user groups) are linked to one or more roles. An 
administrator can assign system-level roles to resources and resource pools. Theses system-level roles govern what 
types of actions are enableed from menus and global access.  System-level roles do not affect the access to individual 
program activities.  As a program manager adds users to an activity, he has the ability to assign specific roles for those 
objects.

For more details on roles and privileges, see Agile 9 Administrator Guide.

Flexible Object Sub-Classing

The administrator or PE program manager can create, delete, or rename the four subclass objects: program, phase, 
task, and gate. This capability is frequently used to create a “Project” subclass for organizations that manage multiple 
projects as part of an overall program. The administrator also can toggle the tabs for each subclass, per subclass 
object. 

Note Since deliverables in Agile 9 are not independent objects, but rather are handled through a tab on activities, 
it is not advisable to create a “Deliverable” subclass.

Additional Flex Fields

An administrator can add more flex fields to particular pages. For example, you may want to create a new field called 
Department to appear on pages associated with discussions. You might create three values for this new field:

❑ Engineering, 

❑ QA, and 

❑ Human Resources. 

The Department field would appear with these three values on pages where you can create or edit discussions.

Note Those who add flex fields should have a thorough understanding of the new Dashboard category fields.

Workflows for Programs 

Workflows are used to manage the stages an object goes through in its lifecycle. The default workflows ensure that 
all routable objects match certain criteria at each stage of their life cycle. Only one status type is required, Pending. 
Status properties define some specific actions that can either be automatically triggered or manually performed. For 
example, a change in workflow status of a deliverable can trigger a status change in a gate. Additional workflows can 
be created as necessary. 

Program Management with Agile PE
The program management objects and features in Agile PE enable you to: 

❑ Define a program in terms of its schedules, tasks, resources, and deliverables

❑ Plan, execute, and manage multiple related program/phase/gate processes

❑ Associate product deliverables with program objects
1-3
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❑ Establish templates that can be reused in other programs

❑ View resource workloads by user and resource pool 

❑ Characterize programs according to organizational, product and program types and view portfolio level 
dashboards and reports

You use program objects to schedule and execute programs. Each program not only contains schedule information 
but also the attachments, discussions and actions items, resources and roles, and history of all activity related to the 
program. For management visibility, data is rolled up to higher levels by rules and parent-child relationships . (See 
“Status Roll-Up” on page 1-5.)

Status management of the leaf-node object (an object with no children) is driven by schedule, cost, resources and 
quality. With the exception of schedule, all statuses are optional and can be set to Off for each object. Schedule status 
is automatically set by the system based on current date versus expected due date.

Once an activity (program) has been created, you can add the following elements to it:

❑ Programs

❑ Phases

❑ Tasks

❑ Gates

Note Program, phase, task and gate are out of the box subclasses provided by Agile. They are customizable. For 
instance, a customer may choose to create a project subclass to manage projects.  In this case the program 
subclass is typically used for the higher level parent of related projects.

These objects are discussed in “Program Management Objects” on page 1-4 and in Chapter 4. 

The program management process involves management of scheduling, tasks, status, discussions, documents, 
phases/gates, and resources.

Program Management Objects 
A typical Agile PE program consists of: 

❑ A root-level program at the top, containing multiple child objects, such as 

❑ A series of phases or other programs, each of which can contain

❑ Other child activities, such as tasks, but possibly also including other programs and phases. At the lowest level, 
child objects which have no children are referred to as leaf objects. 

The components of an Agile PE program are listed in the following table. 

Table 1-1: PE Object Types 

Icon Object Description

Program A program is a set of related activities and milestones (gates) that is created to monitor 
and manage progress on a specific project. A program is the top-level object, but a 
program can also be a child of another program.

Phase A phase, sometimes called a stage, is a segment of a program. Phases are often used to 
define a set of deliverables. When phases end, a phase exit or gate review can be held to 
examine the completion status of each phase element. Phases usually derive their dates 
and status information from the program elements that report to them.

Task A task is a segment of work that one or more resources can complete over a period of 
time. Progress or status reported in a task is rolled up to higher levels of the program. 
Tasks may be embedded in programs, phases, or other tasks.
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Properties of PE objects

Owner and Delegated Owner

A person who is responsible for an activity or gate is called the owner of that object. In Agile PE, there is only one 
Owner of an object (task).  He or she is the sole person responsible for updating the status and completing the task. 
A user who creates a new program or activity is the owner of that object.

There may be several resources on the task, who have allocated hours to support getting the task done.  In addition, 
there are team members who typically have read access but do not have time allocated to completing the task or 
assisting the owner in the completion of the task.

The program manager or owner can assign the ownership of the individual program objects to other users by 
delegating the task. The delegated owner receives a request. On acceptance, a delegated owner becomes owner of the 
task. A delegated owner is given the PE Program Manager role for the delegated object.

Note The original owner loses edit rights to the program object once the new owner accepts it, unless he/she has 
edit rights to a higher-level object.

For information about how to delegate ownership, see “Delegating” on page 3-14.

Status Roll-Up

A number of attributes are passed upward from child objects to parents, a process called rolling up. The attributes 
that are rolled up are activity workflow status, health statuses, scheduled dates and scheduled duration, actual start/
end dates, estimated start/end dates, days effort, and percent complete. 

The rolling up of values starts with leaf nodes (child objects that have no children) and moves upward to parent 
objects. So, for example, if any one leaf node object is in the Off Track health status, the parent will be Off Track. 
This process occurs for objects that are not in the Complete or Canceled workflow state.

Editing on parent objects is disabled for fields where the child objects roll-up.  For example, in most cases you cannot 
edit Days Effort or Scheduled Dates at the program level.  This information is automatically rolled up from lower 
levels in the hierarchy.  This data can only be edited at the lowest levels (leaf nodes).

Gate A gate is a special milestone that denotes the completion of a set of related activities, 
such as a phase. Gate status is frequently controlled by deliverables. A gate’s status is 
closed until all its deliverables are complete, at which time it opens so work can go 
forward (“through the gate”). The change in the gate’s workflow status can be 
automatically triggered by the status of deliverables, so that when all deliverables reach 
a certain status, the gate opens. 

Deliverable An Agile object whose state change can trigger a state change in the program element 
that contains it. When the deliverable changes to a predefined target workflow status, 
the event triggers a change of status in the activity to a predetermined new status. 
Deliverables are often used to control the status of gates.

Discussion Informal conversations relating to a specific activity, found on the Discussions tab.

Action Items Unplanned task with owners and due dates, found on the Discussions tab. Action items 
can be attached to discussions or to the program object.

Table 1-1: PE Object Types  (continued)

Icon Object Description
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Figure 1-1: Workflow status stamp (left) and health status indicators 

Health Status

The activity Health Status indicators appear in the upper right of the activity window. 

Whether health values roll up from a child object to parents or not is controlled by the Rollup Health Status value 
in each object’s General Info tab. This value can be set to No for any objects whose status should not be rolled up. 

If the Rollup Health Status field is set to Yes, all status elements (Overall, Schedule, Cost, Resource, Quality) are 
rolled upward from child to parent. For example, if any one child of a program is Off Track, the parent program is 
set to Off Track; if the Quality Status of a child is Below Quality, the parent is set to Below Quality. 

Health attribute values are maintained in administrator settings, and each value has an associated activation period 
or value. 

Colors indicating stages of the health are:

On Track (green)

Needs Attention (yellow)

Off Track (red)

Default Health Statuses

The default schedule, cost, resource, and quality health statuses are as follows:

❑ Default schedule statuses: The values are On Track (green), Needs Attention (yellow), Off Track (red). The 
default is to change the health status from Not Started or On Track to Needs Attention if the task is overdue by 
more than one day and less than 5 days, and to change status to Off Track if the item is overdue by more than 5 
days. An agent runs in the background to monitor dates and automatically sets the schedule status.

❑ Default cost statuses: The values are On Budget (green), Off Budget (yellow), Over Budget (red). 

❑ Default resource statuses: This values are Staffed (green), Understaffed (yellow), Not Staffed (red).

❑ Default quality statuses: The values are Meets Quality (green), Below Quality (yellow), Poor Quality (red). 

❑ Default overall object statuses: The overall status corresponds to the highest severity of the four health statuses. 
As a result, it denotes the worst of these status values (cost, resource, quality, and schedule). 

The Agile administrator can customize the names and order and manage the severity level that triggers a change in 
health status. 

Reason fields

When you edit statuses in the General Info tab, fields are provided where you can enter a reason for a status. For 
example, if you set the Cost Status field to Off Budget, you might enter “high shipping costs” as the reason. This 
information will appear on the General Info tab of the object, and the status will be rolled up to parent objects. 

Workflow Status

Agile Web Client uses a workflow stamp in the upper right of the General Info tab to indicate the workflow status of 
an activity (see Figure 1-2). The Agile administrator defines the name of each status in each workflow. 
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Your Agile administrator may have created customized workflows and status stamps for your company. The default 
program workflow statuses are:

❑ Not Started

❑ In Process

❑ Complete

❑ Canceled

See “Workflow Tab” on page 3-11.

Users with the privilege to Change Status on the object can do so by selecting the Change Status button on the activity. 
This enables the user to promote the activity to the next lifecycle state.

Important Changing the status can only be done on leaf node objects (objects with no children).  The lifecycle status 
on parent objects is rolled up from lower levels.  In addition, for activities whose type is Proposed or 
Template, the Change Status button is disabled at all levels.
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CHAPTER 2
Installation Notes

This chapter provides notes on installation and set-up issues specific to Agile Program Execution. 
For complete information on Agile product installation, see the Agile Installation Guide.

Program Execution User Licenses

Agile Program Execution is licensed per server, with a predetermined number of concurrent and power user licenses.  
Users are assigned as either a concurrent or power user by the administrator using the Java client.  

Once the PE system is activated and users are designated as either concurrent users or power users, the Agile 
administrator assigns roles that govern system-level access and functionality, according to the requirements of each 
user’s job.  For example, if a user’s job requires them to Create new programs from the Create menu, the 
Administrator typically assigns them the system-level Program Manager role.

However, any user who owns a task or a program object can add users to the team for that object and assign an 
object-specific role. (The potential roles that may be assigned vary, depending on the nature of the program object.)

For more details on licenses, including a description of what privileges attach to a power user, see the Agile 9 
Administrator Guide.

Configuration in Japanese and Chinese 
❑ Agile PE database instance can only be configured to use UTF-8 language encoding. Agile PE sets the browser's 

character encoding to UTF-8, and it is not recommended to change the character encoding setting in the 
browser.

❑ The Agile PE Gantt application requires the International JRE (Java Runtime Environment) on client systems. 
The Japanese and Chinese JRE versions are not supported.
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CHAPTER 3
The Executive Dashboard

This chapter discusses the Dashboard, which provides cross-program information on all your programs and 
resources. It includes the following sections: 
❑ The Configuration Panel
❑ The Executive Tab
❑ The Programs Tab
❑ The Resources tab
❑ The Financial tab
❑ The My Activities tab
❑ Optional Tabs

The Dashboard enables you to view and manage information across all your programs or activities. Depending on 
your roles, you can get an executive-level view of key information for all your programs, and user-level information 
about the activities, tasks and other information that is specific to you. In addition, you can use reports to see and 
print consolidated information (see “Reports” on page 4-19). 

Note You can make the Dashboard your default start page by going to Settings > User Profile and selecting the 
Preferences tab. Click Edit, and select the Dashboard tab you want as your Preferred Start Page—for most 
users that is likely to be My Activities, but an executive might prefer to open on the Executive tab. 

The Dashboard includes the following sections:

❑ Tabs that enable you to select the view: Executive, Programs, Resources, Financial, My Activities, plus two optional tabs. 
These are discussed in the following sections. 

❑ Windows within each tab, which present pertinent information. The My Activities tab, for example, includes the 
following windows: My Assignments, My Documents, My Action Items, My Issues, Notification Requests. 

❑ The Configuration panel in the upper right, which filters the data as you specify for all the Dashboard tabs and 
windows (based on your access settings). See “The Configuration Panel” on page 3-2.

Note The Executive, Programs, and Financial tabs are populated only for root programs that you have Read access 
to.  This Read access is enabled either by adding a user to the Team of the root program or by establishing 
an Executive (global) privilege. The Executive privilege gives access to all root-level programs with 
matching values for the dashboard category fields that are labeled (by default) Region, Division, Program 
Type, Customer, Launch Year, and Product Line. 

The My Activities tab is always populated with information for the current user. 
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Figure 3-1: The Dashboard

Each Dashboard window includes buttons in the upper right corner, described in the following table.

In the windows that display a table, you can click column headings of most tables to change the sort order. You also 
can click on data in most tables (depending on your privileges) to “drill down” to a view of the individual object. 

The Configuration Panel
The Configuration panel in the upper right lets you filter the data in the dashboard views to show just the information 
that’s most relevant to you.

Table 3-1: Buttons in Dashboard windows

Button Description

 Help Opens the Help menu.

 Maximize/reduce window  Click this button to expand the window so you can view and work with the data.

 Close window  Click to close the window. You can reopen it by selecting it in the Add Content field at the 
bottom of the window and clicking the Add button; or you can click the current tab to refresh 
the view. 

 Download You can download data in comma-separated value (.CSV) format for use in a spreadsheet 
(available in all tables).

Configuration Panel

Window buttons
3-2 Program Execution User Guide



Chapter 3 The Executive Dashboard
Figure 3-2: The Configuration Panel open for editing filter values.

To change the filter settings: 

Click the arrow, or click on any individual filter value, to open the panel with all filters displayed. Change the 
values as desired. Click the arrow again to close it.

For example, an executive can set the dashboard to show all the programs, issues, gates, financial summaries, and 
resources that apply to her division and region, or view a subset she specifies. Once the dashboard settings are 
entered, the executive sees only those programs that are her responsibility. 

Note If a root program has a value set to "All" then, by design, it will show up in all views no matter what value 
is selected in the configuration view for that field.  All is interpreted as including the specific value.

A functional manager who owns resource pools might want to identify on the Resource tab specific resource pools 
for consideration. The list of available pools are all the pools that the functional manager owns in the solution. This 
manager would then easily see all off-track activities for tasks assigned to people in his pool. 

The Executive Tab
The Executive tab provides portfolio data for the executive who needs to monitor programs and see information 
roll-ups by type of program. It provides a cross section of information on programs that enables the executive to see 
the major risks in terms of schedule, resources, and costs of the programs.

Note The Executive tab contains data only if you have the Executive role, or have read access to root-level 
programs. 

Program Management window

The Program Management window provides a graph of all programs that meet the criteria in the Configuration panel, 
showing their overall status, such as Off Track. The percentage of the total number of programs is displayed for each 
status. Passing the mouse pointer over each segment of the chart displays the count. You can click on each segment 
to display the Programs tab with that group of programs (such as Off Track or Proposed) selected in all windows. 

Note The schedule status is controlled either through roll-up from lower level objects, if they exist, or by an 
agent that runs in the background and triggers a status change based on current date versus the activity's 
scheduled end date. The default setting is that an Activity will turn to Needs Attention after one day and 
Off-Track after 5 days. 
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Resources window

This window displays a table showing the resource pool names, data about each one, and the owner. It contains all 
pools and resources associated with the root programs and program objects below them, filtered by the settings in 
the Configuration panel. Team members that have zero allocation are not counted. 

You can click a pool name to view or edit the pool details and add or remove members. Resources not assigned from 
a pool are included in a separate line labeled “No Pool,” where applicable.

Note People with pending assignments and those with zero allocation are not included in the head count.

Click the Report button beside the pool name to view the Pool Utilization Summary report. You can also open this 
report by clicking the Pool Utilization Report button in the Resources table. 

Click an owner name to view the User Profile. In this window you can edit information about the user and create a 
Resource Utilization report for the user (if you have the required privileges). 

The data in this window does not include programs that are in the Proposed, Completed, or Canceled states.

Financial window

The Financial window provides a view of the financial performance of the programs in terms of capital expense, 
labor costs, and fixed costs.

The table of programs displays the root program name and an icon representing status, the scheduled end date, the 
owner, and cost data. If the total actual cost figure is over budget, it is shown in red. The Administrator can change 
the names of the cost fields. The cost values are manually entered at the root program cover page.

The Programs Tab
The Programs tab displays information about all programs that you are involved in, including status, gate progress, 
and top priority issues.

Programs window

The Programs window displays all programs to which you have access (subject to the filters in the Configuration panel). 
It includes the root program name, owner, status, start date and end date. 

❑ Click a column heading to change the sort order. 

❑ Click a program name to open the program object. 

The icon next to the program name indicates the status of the program, such as On Track or Needs Attention. 

Gate Progress window

This window shows the gates and their statuses for each program. The number of deliverables/activities required and 
completed for each gate is also shown; the number required is derived from the number of deliverables listed on the 
deliverable tab plus the number of dependencies to the gate. Click a gate or program name to open it. 

The data in this window does not include programs that are in the Proposed, Completed, or Canceled states.

Top Priority Issues window

The Top Priority Issues window shows the top-priority issues by default. You can use the selection list to specify a 
different priority you want to view or select all priorities. You can see the issue number and title, and an icon appears 
if there are Action Items associated with it. 

Click the program name to open it. On the Discussions tab, you can view the issues and click an issue to view its details. 
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The data in this window does not include programs that are in the Proposed, Completed, or Canceled states. 

The Resources tab
The Resources tab provides several views on resource utilization and issues for resource pools that you own or for 
pools that match your privileges. The Resource Pools field at the top of the page lets you select the resource pools to be 
considered, in addition to the filtering provided by the Configuration panel. 

Note Note that category fields in the Configuration panel considers the category fields on the user group objects 
(not programs) for this tab. 

Individual tables or charts can be minimized or maximized in the tab view. They can also be closed in the tab and 
then retrieved through the Add Content list, which appears below the tables when a table is closed. 

Resources window

The Resources window shows each resource pool’s programs and status, in terms of overdue items and 
overallocation. Click a pool name to edit its information, to add or remove members, and to create a report on the 
pool. 

Click the icon to the left of the pool name, or click the pool name and click Report, to create a Pool Utilization report. 

For each pool listed, the associated root programs are listed with the number of unique heads (resources) assigned.  
The # of Pending Assignments column displays the number of assignments that have been delegated to the pool but 
not assigned to a specific resource.  The number of overdue items is a count across all pending and assigned activities 
to the pool within the corresponding program.

The data in this window does not include programs that are in the Proposed, Completed, or Canceled states.

My Pool Members Top Priority Issues window

This window shows the highest priority discussions for each Resource Pool, but you can select other priorities to 
display from the Priority list. An icon shows the program status, and another icon appears at the right if there are 
Action Items. Click a program name to open it; you can view the discussions on the Discussions tab. 

If there is a discussion thread, only the top level issue is displayed. Click the + symbol to expand the display. 

The data in this window does not include programs that are in the Proposed, Completed, or Canceled states.

Resource Pool Summary window

This window shows a graph of the resource pool utilization by program. This enables a manager to see where 
resources are over-allocated, by date. 

As you pass the mouse pointer over each chart segment, you see the program name and the percent utilization of 
resources. Click on a chart segment to open the corresponding program at the Team tab, where you can view the team 
data.

Click the Show Report Options link at the top to view and change report settings. The options let you specify the chart 
type, date range, programs to include, and time intervals used in the graph.

The data in this window does not include programs that are in the Proposed, Completed, or Canceled states.

My Pool Members Off Track Activities window

This window displays programs assigned to your pool members that are in the Off Track state. The data includes 
scheduled and actual dates plus percent complete. 
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Click a Resource Pool name to view and edit the pool, and click a program name if you want to view and edit it. 

The Financial tab
Root programs on this tab can be filtered using the category and status filters in the configuration panel in the PLM 
Dashboard.

Individual tables or charts can be minimized or maximized in the tab view. They can also be closed in the tab and 
retrieved through the Add Content list, which appears below the tables when a table is closed. 

Financial window

The Financial window displays the same data as the Financial window in the Executive tab (see “Financial window” 
on page 3-4).

Chart windows

The three chart windows display the capital expense, labor cost, and fixed cost data in graphic form. When you rest 
the mouse pointer over a graph segment, you can read the program name and the cost amount. 

The My Activities tab
This tab displays activities that you own or are participating in. 

Programs on this tab can be filtered using the category and status filters in the configuration panel in the PLM 
Dashboard. Individual tables or charts can be minimized or maximized in the tab view. They can also be closed in 
the tab and retrieved through the Add Content list, which appears below the tables when a table is closed. 

My Assignments window

This window lists the programs, phases, tasks, deliverables and gates that you own. An icon indicates the status of 
each assignment. You can change the sort order by clicking on column headings—to view the assignments 
alphabetically, for example, or to sort by start or end date. 

My Documents window

The My Documents window lists all documents associated with your programs, with the document description, size, 
and other data. 

To open a file, click the file name. 

My Action Items window

This window displays all your action items, along with status and due date. Click the program name to open it, and 
select the Issues & Action Items tab to see details of your action items. 

My Issues window

This window includes all discussions created by you for the selected set of programs (not just your top priority 
discussions). The data includes the program name, issue number, and issue title. Click the program name to open 
the program, and select the Issues & Action Items tab to see details of your issues. 
3-6 Program Execution User Guide



Chapter 3 The Executive Dashboard
Notification Requests window

The Notification Requests window displays your notifications, including the type and description, sender, and date 
received. Click the program name to see the details.

Optional Tabs
Two optional tabs are provided that can be configured as needed. You can define searches that return data you need 
to see in these tabs. 

Individual tables or charts can be minimized or maximized in the tab view. They can also be closed in the tab and 
retrieved through the Add Content list, which appears below the tables when a table is closed. 

To create new window data: 

1 Click the Add button and use Advanced Search to define the content you want. The content can include any Agile 
objects. 

You can use an existing saved search for the display results by selecting the Use Saved Search option. 

2 Once you have defined the search you want, click the ... button next to the Table Name field and enter a display 
name for the table. 

Click the Delete button if you want to delete the existing search and clear the search results.

The filters of the Configuration Panel do not apply to the content of the optional tabs. 
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CHAPTER 4
Creating and Managing Programs

This chapter discusses how to create and manage Programs. It has the following main sections:
❑ Creating a Program Structure
❑ Creating and Using Activities
❑ Creating and Using Gates
❑ Activities Tabs
❑ Actions Menu
❑ Inbox Pages
❑ Resource Pools
❑ Importing from Microsoft Project
❑ Reports

Creating a Program Structure 
When creating a new program, the easiest way to build the structure is to start at the top and work down. The general 
procedure is to create the root-level program first and then create the child objects. To create a program structure,

1 Use one of the methods described in the following section to create the root-level program object. Be sure to 
select program as the object type. 

2 Go to the Schedule tab of the new program, and click Add. Create the first child object. All objects created from the 
Schedule tab are children of the current object. 

3 Repeat the process to create additional children, as needed

4 Open each child object and create its children, as needed.

Once you have the structure in place, you may want to save it as a template, to make it easier to create future 
programs; see “Using Save As to Create a Template” on page 4-14.

Creating and Using Activities
An activity can be a program, phase, or task. You can create an activity in the following ways:

❑ By defining the program yourself using the Create menu. 

❑ By clicking the Add Activity button in the Gantt chart. 

❑ By importing an existing project from Microsoft Project.

❑ By choosing Save As from an existing object.
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Creating an Activity Using the Create Menu

To create a new activity: 

1 Launch the Agile Web Client. 

2 From the Create menu on the main toolbar, select Program > New. The Activity Creation Wizard appears. Or select 
Program > From Template, and select the template you want to use to create the program (see “Using Save As to 
Create an Activity” on page 4-2).

3 Select the activity type from the Activities Type drop-down list. Fill in the required fields such as Name, Schedule Start 
Date, and Schedule End Date. Click the calendar icon on date fields for a drop-down calendar to assist you in finding 
the appropriate day. Click Next when done, or click Finish.

4 On the Enter Cover Page Information page, enter the information about the program. 

• Select Yes in the Rollup Health Status field if you want this information rolled up to parent objects (see “Status 
Roll-Up” on page 1-5).

• The Change Status button is only available for objects whose Template field is Active in the General Info tab. You 
cannot change status of objects whose Template field is Proposed or Template. Changing the Template field must 
be done at the parent level, and child objects are automatically moved to the value of the parent. 

• You select Template on the Cover Page if you are creating a new template without using Save As.

5 When done, click Next if you want to add an attachment, or click Finish. The General Info tab of the new object 
appears.

If you use a template, you become the owner of all activities in the plan.  You then need to delegate ownership to 
various resource pool owners or team members.

Creating an Activity in the Gantt Chart

To create a new activity while using the Gantt chart, click the Add Activity button or type Shift+A. For details, see 
“Adding an Activity” on page 4-3. 

Creating an Activity Using Save As

You can use the Save As command to duplicate an activity and all its information, including schedule, structure, 
team, dependencies, deliverables, and general information. 

To use Save As to create a new activity: 

1 Choose Actions > Save As to save the current activity under a new name. 

2 Select which components to copy. 

3 Click Finish when done. The General Info tab of the new activity appears.

Creating a Program by Importing from Microsoft Project 

You can import projects created in Microsoft Project for use in Agile PE. For details, see “Importing from Microsoft 
Project” on page 4-18.

Creating and Using Gates
A gate is a special milestone that denotes the completion of a set of related activities, such as a phase or some other 
set of tasks. Gates usually change state based on the state change of one or more deliverables. A gate is a leaf node, 
meaning it has no children. 
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The status of a gate can be Closed or Open. The default is the Closed state. A gate is closed until all its deliverables 
have been met. At that point, it becomes Open, meaning the program can now proceed through the gate. 

The Approval Items and Deliverables tabs display objects and deliverables that are required for the review and approval 
process of the Gate object. 

A gate is created as the child of another program element. To create a gate: 

1 Go to the parent activity. 

2 On the Schedule tab of the parent object, choose Add and specify Gate as the object type. The Add Activity wizard 
appears. 

3 Fill in the information for the gate.

4 Click Finish. The General Info tab of the new gate appears.

Once you have created the gate, you can go to the Approval Items tab and click Add to add activities that need to be 
monitored during a gate review. 

You also can go to the Deliverables tab and click Add to add deliverable objects, which can be used to control the status 
of the gate. 

To add deliverables to a gate: 

1 Click the Add button in the Deliverables tab

2 Use one of the search options to locate and select the objects you want to add. 

3 In the Information wizard page, fill in the fields:

• In the Event field, select the target workflow status which the deliverable must reach to trigger a status change 
in the gate.

• In the <Gate name> Result field, select the status that the gate should move to once all deliverables have reached 
their target statuses. Usually this is Open, meaning the gate should open when the deliverables have been 
completed. 

4 Click Add More if you want to add more deliverables to the gate, or click Finish. 

You also can add dependencies to a gate, as with other activities.  Only the dependencies are accounted for in the 
rescheduling of the project plan.

Activities Tabs
The following sections describe the tabs of an activity.

General Info Tab

The General Info page tab contains Activity and Status Information. 
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Fields on the General Info Tab

The Program General Info tab contains the following fields: 

Table 4-1: General Info tab fields 

Field Contains...

Schedule Contains information that enables you to quickly track program progress. Tells you the 
targeted start and finish dates as well as the duration remaining until program completion. 
The Complete field tells you to what percent the program is complete.

Estimated Contains information that enables you to track when overdue items will be delivered. 
Estimated dates for a child object are entered by the owner of the object and will roll up to 
the estimated dates of the parent object in the same manner as scheduled dates.

Actual Actual varies from schedule if you are ahead of or behind targeted program dates. 

Activities Type Displays whether the activity is a program, phase, or task.

Owner The program owner. See “Owner and Delegated Owner” on page 1-5 for more details.

Delegated Owner The user who has been assigned the activity. Becomes the owner once he/she accepts the 
delegated object. If a user has been delegated ownership but has not accepted the request, 
they are listed as the Delegated Owner. See “Owner and Delegated Owner” on page 1-5 for 
more details.

Name The name of the activity.

Description Text that describes the program. The maximum length is set by the Agile administrator.

Root Parent A link to the root parent object.

Parent A link to the parent object.

Template Indicates the type: Active, Proposed, Template. Only an Active program can undergo 
changes in workflow status. 

Audit Score The audit score for the activity. See “Audit values” on page 4-5.

Weight Weight assigned to the activity. See “Audit values” on page 4-5.

Weighted Score A calculated score based on the audit score times the weight. See “Audit values” on page 4-
5.

Status Indicates the workflow status of the program.

Rollup Health Status Indicates whether the health status rollup is selected or not.

Schedule Status Reason Describes the schedule status for the program object.

Cost Status Denotes the cost status for the activity. This value is a selected value for the leaf object and 
a rolled-up value for a parent object. 

Resource Status Denotes the resource status for the activity. This value is a selected value for the leaf object 
and a rolled-up value for a parent object.

Quality Status Denotes the quality status for the activity. This value is a selected value for the leaf object 
and a rolled-up value for a parent object. 

Workflow Identifies the object’s assigned workflow.

Overall Status An overall status of the activity. This value is calculated based on either selected or rolled 
up-values for cost, resource, /quality, and schedule. It denotes the worst of these status 
values (cost, resource, quality, and schedule).

Program Type Dashboard field. May be renamed during implementation.

Region Dashboard field. May be renamed during implementation. 

Division Dashboard field. May be renamed during implementation. 

Product Line Dashboard field. May be renamed during implementation. 

Customer Dashboard field. May be renamed during implementation. 

Launch Year Dashboard field. May be renamed during implementation. 

Global Controls whether the program is available to all executives or not. 
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Editing a Program

To edit a program, click the Edit button. Make changes in the editable fields, and click Save to save the changes, or 
Cancel.

Some fields on the Program page will not be editable if the program has elements reporting to it.

Duration 

Objects within a program can have different duration types such as:

❑ Fixed duration—The object takes a defined period of time (for example, five days). For Fixed duration type, the 
Days Effort is calculated as the Scheduled Duration times the sum of the % allocation of all resources.

❑ Effort driven—The objects’ Days Effort is fixed, but the number of resources assigned affects the scheduled 
duration. For Effort Driven Duration Type, the Scheduled Duration is calculated as the Days Effort divided by 
the sum of % allocation of all resources.

❑ Calculated—This applies to parent objects and is set by the system. You cannot edit this duration type. 

❑ Effortless—An Effortless activity can have any scheduled duration (such as six months), but the Days Effort is 
zero.

Note If a parent changes to a leaf node object (an activity with no children) then the duration type changes from 
calculated to fixed. The duration remains same as it was when it was the parent. If the parent object had 
resources, Days Effort is calculated based on the % allocation of the Resource/Groups assigned to the team 
tab. If there are no resources, days effort is the same as the scheduled duration. A zero duration parent 
changes to a zero-duration child node.

Audit values

The General Info tab of activities contains Audit Score and Weight fields. The objects of a program can be audited, and 
based on performance indicators, the auditor can assign an Audit Score value to each. The weight value reflects the 
importance of the individual object compared to other objects, in the context of the entire program. The Weighted 
Score field is calculated by multiplying Weight * Audit Score. 

Schedule Tab

The Schedule tab displays the activities and schedule of the current activity and its children in a hierarchical fashion. 
For a root program, it contains all the activities required to complete the program and, if necessary, the resources 
(people) needed to complete those activities. If anything about your program changes after you create your schedule, 
you can update the activities and resources, and Agile adjusts the schedule for you. 

To open a program, click the link in the name field. 

You must have the appropriate privileges to work with the Schedule tab.

Cost fields Monetary fields that are used in the dashboard and reports.  These are intended to track 
program level costs.  Future releases will provide for task-level tracking and automatic cost 
roll-up.

Time Fields Data for these fields is manually entered using Edit.

Custom fields Fields that can be configured by the administrator.

Table 4-1: General Info tab fields  (continued)

Field Contains...
4-5



Agile PLM 9
The Schedule tab has the following buttons:

Removing a Program Element

To remove a program element:

1 Select the checkbox for the object you want to remove.

2 Click the Remove button. A warning message appears asking you to confirm that you want to remove this program 
object. Choose OK in the confirmation message if you want to remove the program element from the database. 

Note Only an administrator or PE program manager or resource pool administrator may delete a program. An 
owner may delete a phase, task, deliverable, or gate. Discussions and File Folders are not deleted from the 
system; they are removed from the program and become stand-alone objects in Agile when the activity is 
deleted.

Edit Menu Options

The Edit menu on the Schedule tab opens the Dependencies, Display Order, Reschedule, and Add Team wizards. A 
checkbox in the menu indicates that you must select an item before using the menu choice. 

Dependencies

A dependency between activities means that one activity must finish before the next one can start (see “Dependencies 
Tab” on page 4-7). 

Select at least two activities in the list of child objects, and choose Edit > Dependencies.  The window that opens lets 
you create or edit dependencies between activities selected by entering the line item number. You also can establish 
and change dependencies using the Gantt chart (see Chapter 5). 

Editing the Display Order

You can change the order in which tasks or phases appear on the Schedule Page tab. 

To edit the sequence of the Program elements on the Schedule tab: 

1 On the Schedule tab, select Edit > Display Order. The Display Order page appears. 

2 In the boxes in the Line # column, enter a number that represents the order in which you want the corresponding 
program elements to appear on the Schedule tab.   

3 Click Save when done. 

Table 4-2: Schedule Tab buttons 

Button Description

Expand enables you to see all child activities associated with the selected activity. 

Remove enables you to delete the selected child object.

Edit Enables you to edit dependencies between the child tasks within the root program, reschedule 
child task activities, change display order of child activities, and add a team. 

Add Enables you to add new object (program, phase, task, gate) to the program schedule using the 
Add Activity wizard.

Create Baseline Enables you to create baseline (see “Creating a Baseline” on page 4-7).

Remove Baseline Enables you to remove a baseline.
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Rescheduling a Program 

To reschedule your Program:

1 From the Schedule tab, select Edit > Reschedule. The Reschedule page opens. 

2 Click the button beside the Move forward () days field to move the schedule date for the program element forward. 
Click the button beside the Move back () days field to move the schedule date for the program element back. Or you 
can use the Start Date or End Date fields to adjust the schedule. 

For more field and button information on this page, see “Schedule Tab” on page 4-5 

3 Click Save to reschedule the program. 

Adding to the Team

You can select single or multiple activities and add team members or resources (the default allocation is 100%). 

To add members to a team from the Schedule tab:

1 Select one or more activities and select Edit > Add Team. 

2 Search for a name by typing the Search Name and clicking Find. Or view all available users by leaving the Search Name 
box empty and clicking Find. 

3 Select individual team members from the Available Users list, and click the arrow to move them to the Selected Users 
list. You can use Ctrl+click and Shift+click to select multiple users. Click Next. 

4 Select the appropriate roles for these users from the Available Roles list, and click the arrow to move them to the 
Selected Roles list. 

5 Check Apply to Children if you want the users roles to apply to the current object and child objects. Click Finish. 

Creating a Baseline

Baselines are used for comparing actual progress with your original plans. A baseline is essential for tracking 
progress. The original estimates it contains are permanent reference points against which you can compare the 
updated task structure, schedule and actual dates.

You create baselines only for the root program object so you can take snapshot of the schedule.

To create a baseline: 

1 From the Schedule tab of a root program, click the Create Baseline button.

2 Enter a description for the baseline, and click Save. 

Once you save a baseline, you can compare the current schedule with any baseline by selecting the baseline from the 
Version list. 

If you need to take snapshots of extensive program data during the planning phase, save multiple baselines. For 
example, you may want to do this at major planning milestones. 

You can remove a baseline by selecting the baseline in the Version list, and clicking the Remove Baseline button. When 
you remove a baseline, the references to the baseline for all objects in the tree are also removed.

Dependencies Tab

The Dependencies tab displays a list of all the predecessor (Dependent Upon) and successor (Required for) 
information of the program. If you have established dependencies to other activities, links to these are also shown. 
All dependencies are Finish-to-Start (FS). 

This tab contains the following buttons:
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❑ Edit—lets you edit dependencies between the child tasks within the root program. The Edit button affects only the 
checked items on the current page. 

❑ Remove—deletes the selected object. The Delete button affects only the checked activities in the current page.

❑ Add—lets you add a dependency between the child tasks within the root program. You can add an element whose 
completion is essential to the start of the current program using the Add Dependencies wizard. Dependencies 
can be made between activities in the same program. 

To add a dependency, click Add. 

To edit or delete dependencies, select the checkboxes of the rows you want to affect, and click Edit or Remove. 

To open an activity, click its name.

When creating or editing a dependency, you can enter a value in the Time Buffer field that represents “slack time” 
between the end of the predecessor activity and the start of the successor. 

You can also create and change dependencies from the Gantt chart view. See “Creating a Dependency” and “Editing 
a Constraint” on page 5-5.

Team Tab

The Team tab lets you manage the team member list for the activity. The Team tab enables you to add or remove team 
members, change team members’ roles, and change their allocation. You must have the appropriate privileges to 
work with the Team tab.

To add team members or a group and apply roles: 

1 Click Add. 

2 Search for a name by typing the Search Name and clicking Find. Or view all available users by leaving the Search Name 
box empty and clicking Find. You can select All Groups to assign a resource pool as a placeholder if the specific 
user is not known.

3 Select individual team members from the Available Users list, and click the arrow to move them to the Selected Users 
list. You can use Ctrl+click and Shift+click to select multiple users. Click Next. 

4 Check the Add As Team Member Only box if you want the new people to be team members but not resources. Or 
uncheck the box and fill in the percent of their time that will be dedicated to this task in the % Allocation field. 

5 Assign one or more roles by selecting them from the Available Roles list on the left and clicking the arrow to move 
them to the Selected Roles list on the right. 

6 Check the Apply to Children box if you want the team members to be included for all child objects. 

7 Click Finish. 

The selected resources with the roles are displayed in the Team tab. People added as resources are also added as team 
members automatically. 

When you complete the Add action, users added as resources receive an Inbox request to accept/decline the 
assignment. Once the user accepts a request, the Resource Pool owner receives a notification that the assignment has 
been accepted.

You can click the Report button in the Add to Team Wizard: Identify Users to Add page to view one or more user’s assignments 
to decide whom to add to the assignment pool. 

To edit a team member’s resource pool, roles, and % allocation:

1 Select the checkboxes of the rows you want to affect. Click Edit. 

2 Enter the changes you want in the Resource Pool and % Allocation fields. Click the ... button in the Roles column to 
edit roles. 
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3 Click Save. 

Deliverables Tab

A deliverable is an Agile object that can trigger a status change in a PE object. For example, a gate might change to 
Open from Closed when a deliverable moves to the Production workflow status.

Deliverables enable you to add any Agile PLM object to PE objects as triggers to enable cross-business process 
automation.

Affected By Table

The Affected By table displays objects that affect the current activity’s workflow status when their workflow status 
changes. The change in the status of the object is automatically reflected on the Deliverables tab. The fields in the 
Affected By table are described in the following table: 

To Add items in the Affected By table:

1 Open the Activity.

2 Click the Deliverables tab.

3 Click Add... above the Affected By table. The Add Content Related Wizard is displayed. 

4 Search for the object. (Or you can select Create and specify the new object type to create—file folder, document, 
or part.) For information on searching, see the Agile 9 Client Handbook.

Table 4-3: Team tab fields 

Field Description

Click the icon to view Resource Pool Utilization Report. The Resource Pool Utilization 
report provides a user’s utilization based on the % allocation for the selected user. 

Name Name of team member or group.

Assigned From The name of the pool from which the resource is assigned. If the resource is assigned to 
multiple pools, the appropriate pool can be selected.

Roles Role team member plays (as listed in Role column)

Days Effort Days effort corresponds to the total sum for the resource or group. 

Is Resource Identifies the user as a resource or just a team member with no time allocated to the activity. 
This Information is dependent on % allocation of Resource/Team Member / User Group. If 
% allocation is greater than 0, it is Yes, otherwise No. 

Rejected flag This indicates that the resource or pool has rejected the Inbox Request. 

% Allocation For both Fixed and Effort Driven duration type, this value determines utilization of a 
resource or group.

Pool Owner Name of the resource pool owner, if there is one.

Table 4-4: Fields in Affected By table 

Field Name Field Description

Number The unique identification number of the object.

Description The description about the object. 

Event The event to happen in the object in order to change the state of the program to the state 
specified in the Activity Result field. It is also referred to as the target status.

<Activity> Result <Activity> is replaced by for the activity name. The status of the activity will be automatically 
changed to the status specified in this field when the deliverable’s workflow status changes to 
that specified in the Event field.

Current Status The current status of the activity.
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5 Click Next. The Information window is displayed with the selected objects in the table.

6 Select the Event and Result as required. 

Event is the change of state of the Agile object that will trigger a workflow status change in the activity. Result is the 
workflow status that the activity will change to once the trigger occurs. 

Note When multiple objects are listed on the Deliverables tab, all objects must reach their Event state to 
trigger the change in the activity.

7 Click Add More... if you want to add more objects, or Finish to add the selected objects.

Affects Table 

The Affects table displays the objects that are affected by a change in the workflow status of the current activity. 

The fields in the Affects table are described in the following table:

To add objects to the Affects table:

1 Open the activity.

2 Click the Deliverables tab.

3 Click Add above the Affects table. The Add Related Content Wizard is displayed.

If no Affects table is visible, click the Add to Affects Table link below the Affected By table.

4 Locate and select the object using the search or create options in the wizard. For information on searching, see 
the Agile 9 Client Handbook. 

5 Click Next. The Information window is displayed with the selected objects in the table.

6 Select the Event and Result as required.

Event is the change of state of the activity that will trigger a workflow status change in the affected object. Result is 
the workflow status that the affected object will change to once the trigger occurs. 

7 Click Add More... if you want to add more objects, or Finish to add the selected objects.

To edit the object information in both Affected By and Affects table:

1 Check the check box beside the objects that needs to be edited.

2 Click Edit. The objects are displayed in the Edit mode in the table.

3 Make changes to the editable fields as required.

4 Click Save to save the changes.

To Remove the object information from Affected By and Affects table:

1 Check the check box beside the objects you want to remove.

2 Click Remove. A confirmation message box is displayed.

Table 4-5: Fields in Affects table 

Field Name Field Description

Number The unique identification number of the object. (Lets say OBJ01)

Description The description of the object.

<Activity_NUM> Event <Activity_NUM> stands for the unique identification number of the activity. When the status of 
the activity is changed to the status specified here, the status of the object (OBJ01) will be 
automatically changed to the status specified in the Result field.

Result The status of the object (OBJ01) will be automatically changed to the status specified in this field 
when the <Activity_NUM> Event is triggered in the activity object.

Current Status The current status of the object (OBJ01).
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3 Click OK to confirm the removal.

Note There is a limitation to adding objects in both the tables. Objects in their last status cannot be added to 
either of the tables. 

Links Tab

For a product deliverable, the Links tab displays a list of all objects that have reference relationship with the current 
object. Unlike deliverables, there are no requirements or automation imposed between linked objects and the 
corresponding PE activity. 

❑ To add a reference relationship, click the Add button. The Add Related Content wizard opens. 

❑ To delete a reference relationship, select the checkboxes of the rows you want to effect, and click the Remove 
button. 

❑ To open a reference relationship, click its number link.

The table below describes the fields in the section. 

Workflow Tab

The Workflow tab shows where the program object is in the assigned workflow and lists past signoff information. If 
you have the necessary privileges, you can add or remove approvers and observers on this tab, or you can move the 
object to another status in the workflow.

Programs, phases, and tasks roll up their statuses (see “Status Roll-Up” on page 1-5). Default workflows for 
programs contains the following statuses: 

❑ Default Activities Workflow

Not Started —> In Process —> Complete

❑ Default Gates Workflow

Closed —> In Review —> Open

Rules for parent status
❑ Parent object workflows are affected when any of their child workflows start. For example, if one activity is in the 

In Process state, then Parent status is In Process.

❑ Parent object workflows are affected when all of their child object workflows complete. For example, if all 
activities are Complete, then parent status is Complete.

❑ When custom workflows are used, the roll up is governed by the transition between the Status Type, not 
necessarily a change in the step.  For example, a workflow with seven steps can roll up to a parent with three steps 
because each has only one transition between the “Pending” and “Review” type (Pending, Review, Complete, and 
Cancel are the Status Types).

For leaf-node objects, you can click the Change Status button to change their workflow status (provided you have 
the required role). 

For more information about workflows, see the Agile 9 Client Handbook and the Administrator Guide. 

Table 4-6: Fields on the Links tab 

Field Description

Type An icon representing the object type. Rest the mouse pointer on the icon to see the name of 
the object. 

Number The item number. Click to open the Cover Page tab for this Item. 

Description A description of the Item.
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Discussions Tab

The Discussions tab contains both discussions and action items. Users can post and reply to discussions that arise in 
the course of managing programs. Action items ensure that the loop is always closed so that discussions do not go 
unattended. 

Subscriptions are often set up by the team members to get notified as discussions are raised.  This promotes a 
collaborative thread of replies and captures the decision-making and history of a program.

Adding Discussions

You can add a new discussion or reply to an existing discussion. 

To add a discussion: 

1 Open the activity, and click the Discussions tab.

2 Click Add. The Add Discussion wizard appears. 

3 Select the Create button, and select Discussion from the Type drop-down list. Click Next.

4 Enter a subject for the discussion. 

5 Type the message you want to send. 

6 From the Priority drop-down list, set the discussion priority.

7 Click the Notify List field to add users who should receive notification of this discussion in their Notifications & 
Requests inboxes. Click Finish. 

Replying to Discussions

You or your team members or notified users can reply to the discussions. 

To reply to discussions,

1 Click the discussion name to open it. 

In the root program object, you can see which activities have discussions by looking for the symbol in the 
discussions column on the Schedule tab. 

2 On the Discussions tab, select the discussion you want to reply to.

3 Click the Reply button. Enter your message and the list of people to notify, and click Save. 

If you are viewing a list of discussions in your Notifications & Requests inbox, you can reply as follows:

1 In your Notifications & Requests inbox, click the Regarding field (not the Subject field) of the discussion to open the 
discussion item. 

2 Click the Replies tab.

3 Select the button for the discussion you want to reply to. 

4 Click Reply. The Discussion Reply wizard appears. 

5 Add the reply message and the list of people to notify, and click Save. 

To see a list of replies to a discussion: 

Click the + symbol next to a discussion in the Subject column. 

Or you can click a discussion subject to open the discussion object. Click the Replies tab to see all the replies 
related to this discussion.

Removing Discussions

After you finish all your discussions, you can remove the discussion objects. 
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To remove discussions: 

1 Open the activity, and click the Discussions tab.

2 Select the radio button for the discussion you want to remove.

3 Click Remove. 

Action Item Details

You can access action item details from the Discussions tab by clicking the name of the action item. Action Items 
appear separately below discussions in the lower part of the page. 

To add an Action Item: 

1 Open the activity and click the Discussions tab

2 In the Action Item section, click the Create button. 

3 Fill in the action item information. Fields that are in boldface are required. 

4 Click Save.

The action item will appear in the Notifications & Requests inbox of the person you assigned it to.

Attachments Tab

The Attachments tab enables you to attach files and URLs that are helpful or needed for your and your team members’ 
work. If there are items on the Attachments tab, a paper clip icon appears on the tab. 

Note You must have at least edit permissions to add an attachment to a program element.

Refer to “Attachments” in the Agile 9 Client Handbook for details about the Attachments tab.

History Tab

The History tab records all actions taken, such as editing the General Info tab or changing activities or team members. 

Note If you do not have the appropriate read privileges, you cannot view the fields on the History tab. If you have 
questions about your privileges, see your Agile administrator.

Actions Menu
The Actions menu has the following commands: 

❑ Bookmark 

❑ Subscribe

❑ Save as

❑ Delete 

❑ Print

❑ Send 

❑ Sharing

❑ View workflows 

❑ Delegate

❑ Substitute resource

❑ Change parent

❑ Change archive status
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❑ Reports

Some of these commands are discussed in the following sections and elsewhere in this manual. Others that are useful 
with all Agile objects, such as Bookmark and Subscribe, are discussed in the Agile 9 Client Handbook. 

Using Save As to Create a Template 

You can use Save As to duplicate values and other dependencies of existing objects in new objects or templates. 

To create a template:

1 Open the program you want to save as a template. Choose Actions > Save As.

2 Select the components you want to include. 

3 Select Template in the Template drop-down list. Click Finish. 

The General Info tab of the new template appears. 

Note Team member information, discussions, action items, and history are not included in the template. 

Once saved as a template, a program does not appear on active program lists. However, documents continue to be 
stored for the program on the Attachments tab. The template is available to create new programs using the Create > 
Program > From Template command. 

Delegating

When you create a program element, you are made its owner by default. The Delegate command enables you to 
change ownership of a program element.

Note An owner of a higher-level program element retains ownership of lower level items reporting to it, even 
when ownership of the lower level is delegated to another team member. 

To delegate ownership of a program, phase, task, deliverable, or gate: 

1 Open the activity you want to assign to a new owner. 

1 Choose Actions > Delegate.

2 Select a new owner from the team list.

3 If the intended new owner is not listed, add him or her to the team at this time by clicking the Add button on the 
Delegate page. 

A flag will appear beside the new owner's name. It will remain until they have accepted the delegation by accepting 
the request sent to their Notifications & Requests inbox.

Substituting Resources

You can use the Actions > Substitute Resource command to substitute resources.

You can substitute an existing resource for another resource by selecting from a list of people. The current resource’s 
role is assigned to the substituted resource. 

To substitute one resource for another: 

1 Choose Actions > Substitute Resource. 

1 Select a resource to be replaced in the From Resource drop-down list. The list contains all team members including 
those of child activities. 

2 Click the To Resource field and use the ... button to select the To Resource. If you want to substitute the resource in 
all the child activities, select the Apply to Children checkbox.

3 Click the Substitute button.
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Changing the Parent

You can change which program a program element reports to. For example, you can change the parent of Gate A, 
so that it reports to Task A instead of Task B, or have Phase A report to Program 2 instead of Program 1. 

To change the parent of an activity: 

1 Open the activity. 

2 Select the Actions > Change Parent command. 

3 Use one of the search options to locate the new parent. 

4 Select the new parent object, and click Finish. 

Changing the reporting relationship of a program element also changes the rollup status, dates, and progress to those 
of the new parent. 

Changing Archive Status 

You can change the archive status of a root-level program from the Actions menu. Archiving old data can improve 
system performance.

To change the archive status: 

1 Select a root-level object. 

2 Select Actions > Change Archive Status.

When a program is archived, it is removed from all active program lists and from the program navigation tree. All 
buttons and Actions menu choices are grayed out, except for Actions > Change Archive Status. You can select this option 
again to remove the archive status. The archived program’s data remains searchable.

Reports

Use the Actions > Report and Analytics command to view the Program Resource Utilization and Schedule Reports. 

Note The analytics option will be available only if you have installed Analytics.

Program Resource Utilization Report

The Program Resource Utilization report provides a chart summarizing Days Effort Utilization including all the 
children of the current object. This report categorizes the Resource % Allocation by resource pools and users who 
are not members of any resource pools as No Pool. All the tasks for which resources have not been fully assigned are 
categorized as Unassigned.
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Program Resource Utilization by Days Effort Report Fields  

To print the report, click Print button. 

To export the report, click Export to CSV button. The report will be exported into the comma-separated value format 
(.CSV), which can be opened in Microsoft Excel.

Schedule Reports

The Actions > Report and Analytics > Schedule option opens the Schedule Reports page. Schedule reports provide a complete 
view of the schedule. Values for status and ownership can be selected to apply filters to the list of activities.

You can customize the report by selecting values in the Owner, Status, and Health fields. 

The schedule report has the following fields:

Click the Print button to print the report. 

Other reports are discussed in “Reports” on page 4-19.

Table 4-7: Program Resource Utilization by Days Effort Report Fields 

Fields Description

Program Name of the activity type such as program or phase.

Owner The owner of the activity.

Scheduled Start/End The schedule start and end dates of the activity.

% Complete The % of the activity completed.

Status The workflow status of the activity.

Report Type Types of report; defaults to Program Utilization report. 

Chart Type Select the type of chart: Non-Graphic, Line, Area, Stacked Area, Bar, Stacked Bar, Stair.

Start/End Dates The start and end dates for duration-based assignments such as phases and tasks. 

Pools Select the resource pools assigned. By default all the existing pools are selected. But you can filter 
the data displayed in the report based by changing the selections. 

Reporting Intervals Report by day or other interval.

Scheduled End The schedule end date of the program

Status Status of the activity from where the report has been run.

Chart Type A drop-down list containing the available chart types.

End Date The scheduled end for the activity. 

Reporting Intervals A drop-down list to select the reporting intervals such as month, day, week, quarter, and year.

Table 4-8: Schedule report fields 

Field Description

Name The number of the program.

Description The schedule description.

Owner The program owner.

Schedule Contains information that enables you to quickly track Program progress. Tells you the targeted 
start and finish dates as well as the duration remaining until Program completion. The 
Complete subfield tells you to what percent the Program is complete.

Actual Actual varies from Schedule in so far as you are ahead or behind targeted Program dates. It 
tracks actual time spent on a Program. 
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Change Status button

The Change Status button lets you change the workflow status of leaf objects (objects which have no children). The 
status of parent objects cannot be changed directly, since it is changed by rolling up the status from leaf-level objects. 
You must have the appropriate privileges; by default, the Program Manager and Program Administrator roles have 
the required privileges. 

Note The Change Status button is only available for objects whose Template field is Active in the General Info tab. 
You cannot change status of objects whose Template field is Proposed or Template. Changing the Template 
field must be done at the parent level, and child objects are automatically moved to the type value of the 
parent. 

Inbox Pages 
As information passes through the Agile system, you receive news of status changes, requests, and other notifications 
through email. The Inbox contains notifications, action items, and activities that require your review and action. The 
Inbox contains:

❑ Notifications and Requests

❑ Workflow Routings

❑ Program Activities

❑ Actions Items

❑ Resource Pools

In all the inboxes, you can click on a column heading to sort on that column, and click it again to reverse the sort 
order. 

Notifications and Requests Inbox

The Accept button lets you accept requests sent to you from other users. A typical request will ask you to join a team 
or to assume ownership of a task or deliverable. If you have any pending requests, you will be prompted to reply. 
Acceptance of a request updates the item with your response. An accepted request is removed from the Inbox. 

Select an item and click Delete to remove it from your inbox.

Use the Type field to view only notifications or only requests, or both.

Note Using the Type field can help you respond to requests by grouping them all together. When you open a 
request, you will see fields that enable you to accept or decline. 

Workflow Routings Inbox

The Workflow Routings page displays a list of all objects (activities and gates) that are undergoing a change in status, and 
for which you are an approver or an observer.

For more details on workflow, see “Routing Objects with Workflows” in Agile 9 Client Handbook.

Program Activities Inbox

Items in the Program Activities list are items that you own. No other person has these items appear on their Inbox page. 
This content depends on your role in programs and your privileges. 

Alongside the name of each activity is an icon representing the type of program element that it is associated with, 
and its status. Pause the mouse pointer over the icon to see the current workflow and health statuses. 
4-17



Agile PLM 9
Icons indicate deliverables, discussions, action items, and attachments. Click the icon to go to the corresponding tab 
of the program element.

Action Items Inbox

The Action Items inbox lists unplanned tasks from all your programs. The default list shows action item emails that are 
due within one week. Change the time frame to show items due beyond a week or to view all your action Items. 
Completed action items are not included in this field. 

Display Due In: You can view activities due in the next week or up to six months. You can also choose to view all 
activities. The default list shows activities which are due in one week or are overdue. Completed activities are not 
included in this field.

The Edit button above your action items list lets you edit the Status and % fields for the selected rows. When you click 
Edit, these fields become active so that you can make changes to them. Use the Save or Cancel buttons when done. 

Note A parent activity cannot be edited. 

Resource Pools Inbox

The Resource Pools inbox contains the Resource Pools for which you are the owner. This page contains the pool 
name, owner, and, description of the pool. The administrator, PE program manager, or resource pool administrator 
creates resource pools and assigns owners and users. 

Clicking the pool name link opens the resource pool. (The ability to view or create Agile PE objects and assign users 
as resources is determined by your privileges.) 

Resource Pools 
A resource pool can be created by an Admin by choosing Administration > User Groups in the Agile Web Client. Create a 
user group, or edit an existing one, and set the Resource Pool field to Yes. 

On the Assignments tab, you can view the assignments for the members of this group. You can also analyze resource 
utilization and capacity at an individual user level, at a resource pool level, and at a program level using the available 
reports.

The Assignments field is a drop-down list where you can select the assignments to include in the display. 

Click the icon in the Resource column to view the Resource Pool Utilization Report. This report provides a user’s 
utilization based on % allocation for the selected user. 

To create the other reports, click the Assignment List Report button or the User Group Utilization Report button and follow 
the wizard instructions. 

Importing from Microsoft Project 
The Microsoft Project Macros option enables you to download the macro that lets you save Microsoft Project data in an 
XML format that can be imported by Agile. 

Agile PE has macros for Microsoft Project 2000 and Microsoft Project 98. Please contact the Support team if you 
have any other version.

Note Users of PE 8.5 must uninstall the 8.5 macros before installing the 9.0 version. In Microsoft Project, go to 
Tools > Organizer > Modules and delete the Get File and XML macros from Global.mpt. 

To install the Microsoft Project export macro,

1 In Agile PE, choose Tools > Microsoft Project Macros and download the required macro file: 

• If you have Microsoft Project 2000, open the file PE XML MACRO P2000.mpp 
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• If you have Microsoft Project 98, open the file PE XML MACRO P98.mpp

2 Open the .mpp file in Microsoft Project. 

You will see a floating Agile toolbar that has the following buttons:

• Export XML

• Copy Macro to Global File

• Uninstall Macro

• Close Project

3 Click Copy Macro to Global File. After the macro has been copied, a new command appears on the Microsoft Project 
File menu: Publish Schedule to Agile PE.

Note If the Copy Macro to Global File command does not work, you can go to Tools > Organizer > Modules and manually 
move the macros to the Global list. 

4 Click Close Project on the Agile toolbar. If you are prompted to save changes, click No.

You can now export Microsoft Project files to an XML format supported by Agile.

To export a Microsoft Project file to Agile Program Execution XML format:

1 Open Microsoft Project, and open the project you want to copy to Agile.

2 Choose File I Publish Schedule to Agile PE.

3 Specify an XML filename, and then click Save.

Importing a Microsoft Project file

To import a project from Microsoft Project, choose Tools > Import, and specify MS Project Export File (XML) as the 
import type. 

The project can have tasks, milestones, associated dates, dependencies, and resources. Once imported into Agile PE, 
you are made the owner of the program. For more details on importing activities from Microsoft Project, see the 
Agile 9 Client Handbook.

Note Only Finish to Start dependencies are imported. 

Dates are imported as specified in the import file only. If you need to change the dates, you have to do this after the 
import using the Reschedule function. 

Reports
A number of PE reports are available by clicking the Reports icon  in the navigation panel on the left. 

The folders are grouped in folders under Program & Portfolio Reports. Click a report to open it. On most reports you can 
modify settings on the General Info tab and create a schedule on the Schedule tab. 

Click Execute when you want to run the report. For details on reports, see the “Agile Reports” in the Agile 9 Handbook. 

The PE reports are listed in the following table. 

Table 4-9: PE Reports

Folder Report

End User Reports My Action Items 

My Activities and Utilization

My Discussions

My Documents

Portfolio Reports Portfolio Cost
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Portfolio Cross Program Dependencies

Portfolio Deliverable Ga

Portfolio Priority Discussions

Portfolio Status

Program Reports Program Action Items

Program Deliverable Gate

Program Documents

Program Off Track Activities

Program Schedule

Program Top Discussions

Program User Assignments

Resource Pool Reports Pool Member

Resource Pool Utilization

Table 4-9: PE Reports

Folder Report
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CHAPTER 5
The Gantt Chart

This chapter describes the Gantt chart and tells how to use it to view and modify programs and activities. 
The chapter contains the following sections:
❑ Overview
❑ Activity View
❑ Resource View
❑ Other options

Overview
The Gantt chart is a powerful tool for viewing and modifying program, resource and status information. It provides 
a graphical view of program schedules and progress, and tools that let you revise many of the details of activities. 

The Gantt chart is Java-based, and requires JRE 1.4.2 (Java Runtime Environment) to be installed on your computer. 
This happens automatically the first time you click the Gantt Chart button. 

Note Certain firewalls prevent this automatic download. In this case you can download and install the JRE 1.4.2 
from www.sun.com.

Depending on your roles and privileges, you can perform a number of functions using the Gantt chart. The Gantt 
chart has a menu across the top, a toolbar, graphics, and two major panes: the field pane (on the left) and the graphics 
pane (on the right). You can change the size of the field or graphics pane by dragging the divider between them. 

You must create a program before you can view and modify it using the Gantt chart. 

You should use the Lock feature within the Web Client or the Gantt Chart to prevent changes from being made in 
the web client when editing in the Gantt Chart.

The Gantt chart tools let you create and remove activities, create or modify dependencies, and modify other data of 
the activities such as duration. 

Important After making changes in the Gantt chart, you must use the Update button if you want to save your changes 
to the database. Update overwrites any changes others may have made while the Gantt chart was open. You 
must be the program owner to use Update.

To open the Gantt chart:

Click the Gantt Chart button  on the activity page of a parent or root parent object. 

When you start the Gantt chart, two Java JAR files are downloaded to your computer's temporary folder. Once these 
have been loaded, the Gantt Chart appears. 
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Activity View
The Gantt chart opens on the Activity View, or you can select it by clicking the Activity button at the bottom of the 
window. Both the Activity view and the Resource view contain a field pane on the left and a graphics pane on the 
right. 

The table below describes the icons in the Gantt chart toolbar.  

Table 5-1: Gantt Chart Toolbar Buttons  

Icon Name Shortcut Keys Description

Add Activity Shift-A Inserts an activity below the selected activity.

Add Gate Shift-G Inserts a gate below the selected activity.

Remove Activity Ctrl-Delete Removes an activity.

Create Dependency Alt-C Adds a dependency.

Edit Constraint Shift-E Edits a constraint.

Remove Dependency Shift-Delete Removes a dependency.

Remove Selected/Delete Deletes the item from the Gantt chart.

Expand All Ctrl-E Expands all program elements to the lowest-level item 
reporting to the program.

Collapse All Ctrl-Z Collapses all program elements to the highest-level 
item they report to.

Expand/Collapse Activity Ctrl-Enter Expands or collapse all program elements.

Outdent Ctrl-Left Outdents an item, so that a program element no longer 
reports to the higher-level element.

Indent Ctrl-Right Indents an item, making a program element report to 
another item.

Move Up Alt-U Moves an item up the chart within its level. Changes 
the order of the item within the same level. If program 
elements report to the item, these move along with it. 

Move Down Alt-D Moves an item down the chart within its level.  
Changes the order of the item on the Schedule tab.  If 
program elements report to the item, these move along 
with it. 

Zoom In Ctrl-I Focuses on a smaller section of the graphics pane.

Zoom Out Ctrl-O Focuses on a larger section of graphics pane.

Zoom To Fit Ctrl-F Zooms to show the entire program in the visible area.

Display (Table Options) Ctrl-D Enables you to select the various fields to be displayed 
in the field pane.

Update F5 Updates Agile PE with the additions and changes 
you’ve made in the Gantt Chart. 

Lock Ctrl-L Locks the program to prevent changes except those 
made in the Gantt chart. 
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Status icons appear next to the program elements:

Not Started—The program has not started. 

Complete—The program is complete. 

Canceled—The program has been canceled. 

On Track—The program object is on schedule. 

Needs Attention—The program or child objects are 2-5 days overdue.

Off Track—The program or its child objects are more than 5 days overdue. 

Adding an Activity 

To add a program, phase, or task using the Gantt chart:

1 Click on the row below which you want the new activity to appear. The new activity will be a child of the one 
selected.

2 Click the Add Activity icon. Enter the activity name in the Name field. 

3 Specify the subclass—program, phase or task—and the duration type. 

4 Click the Calendar button in the Start Date field. A pop up calendar appears. Choose the Start Date. 

5 Click in the Duration field, and set the duration in number of days.

The parent program will take on the same Duration as child activities.  If more than one activity exists for the 
program, the program’s duration will be calculated to accommodate the earliest start date and latest end date. 

6 The Due Date is automatically computed by adding the Duration to the Start Date (skipping Saturdays and 
Sundays).

If you need to move the new Phase up or down the Gantt Chart (thereby changing which item it reports to), use the 
Move Up or Move Down buttons on the toolbar. 

You can make an activity a child of another by clicking the Indent button. Similarly, select a child activity and click 
the Outdent button to promote it. 

Using the Activity View’s Field Pane

The field pane (on the left) displays a list of the activities and selected fields of the activities. 

❑ You can specify which fields to display by clicking the Display button or typing Ctrl+D. 

❑ You can change field values for some items (date fields, duration, predecessor) by double-clicking directly on the 
field. When you double-click the Schedule Start, for example, a calendar appears, enableing you to choose a new 
start date. 

❑ You can change the order of the fields by dragging them to the desired position.

❑ You can change the column width by dragging the margins to the right or left. 

❑ You can change the parent-child structure. Click an activity to select it, and use the arrow buttons in the toolbar 
to move it in the program structure. 

❑ The ID column represents a work breakdown structure. It is a numerical representation of the hierarchy of a 
program.  This number dynamincally updates based on indent/outdent position, moving an activity up or down, 
and inserting new activities. You can change predecessors by clicking in the Predecessor column and entering the 
ID number of the predecessor you want. If the Predecessor and ID columns do not appear, click the Display button 
(or use Ctrl-D) and select them from the list. 
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❑ You can sort the activities on any column by clicking the column heading. Click the heading again to reverse the 
sort order.

❑ You can open the activity object in Agile by double-clicking it. No changes are made in the Web Client until you 
select Update from the Gantt Chart. Changes in the Web Client are overwritten by Gantt Chart updates, so you 
should Lock the program before editing in the Gantt Chart.

Note Remember that you must click the Update button to if you want to save any changes you make while using 
the Gantt chart.

The Display Options

Clicking the Display button opens the Table Options dialog box. 

The following fields are found in the Table Options dialog box: 

Using the Activity View’s Graphics Pane 

The graphics pane in the Activity view displays graphic representations of the program elements you have created, 
and enables you to make changes using the menus and toolbar options.   

Duration-based items—programs, phases, and tasks—are represented as bar graphs in the graphic pane, enableing 
you to easily vary the start and due dates, as well as the durations, for these items.

A deliverable or gate is placed on the chart according to its scheduled end date. 

In the graphics pane you can:

❑ Create and change dependencies 

❑ Drag bar ends to change start or end date plus duration, or drag the entire bar to change both start and end dates.

❑ Change the labeling on the bars using the options in the Label By menu. 

❑ If you click a bar, a four-headed arrow appears. You can drag the entire task forward or back in the timeline while 
maintaining the duration. 

A duration-based item that is in progress is represented by two graphs: one graph to show the scheduled start and 
end dates, and another to show its actual start and actual end dates. The bar representing the (scheduled) Start Date 
and Due Date is located just above the bar representing the Actual Start and Actual Finish.

A duration-based item that has not yet begun is placed in the location that corresponds to its start date. One of the 
two bar graphs for duration-based items in progress is placed on the chart according to its scheduled start date, and 
the other according to its actual start date. 

Viewing Critical Path and Critical Task

You can use View > Show Critical Task or Ctrl+S to view the program’s critical path elements. Critical path helps you to 
plan all activities that directly affect the completion date of a program. Critical Path is determined by identifying all 
the activities that have slack below a pre-determined number of days. 

Table 5-2: Table Options fields 

Field Description

Table Categories Choose from the list which fields to show in the Field Pane.  To select multiple fields, use 
Ctrl+click or Shift+click.  Choose All to show all the fields, or None to view only the activity 
names.

Horizontal Click the box in this field to show horizontal lines between each row in the Field Pane.

Vertical Click the box in this field to show vertical lines between each column in the Field Pane.
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Critical path activities act as the basis both for preparation of a schedule and for resource planning. They help you 
to see where remedial action needs to be taken to get a program back on track. Critical path can be viewed at root, 
phase or any parent level.

To see critical tasks, use View > Show Critical Task or Ctrl+T. The critical task is the current activity on the critical path. 

Changing Duration 

The task duration can be seen in the Duration column of the field pane. 

To change the scheduled duration of an item from the graphics pane:

Click the beginning or end of the bar graph for the item so the selection boxes appear, and drag to expand it or 
reduce it. 

The Scheduled Start and Scheduled End Dates for the item in the field pane are changed accordingly. 

Creating a Dependency

You can create a dependency between items by drawing links between them on the Graphics Pane. Dependencies are 
always Finish to Start (FS). 

To create a dependency:

1 From the toolbar click the Create Dependency button. 

2 In the chart view, place the cursor on the small box at the right end (end date) of the predecessor item bar. Click 
once. 

3 Position the cursor over the start end of the successor item bar. When the small box appears, click to establish 
the dependency. (You cannot establish dependencies between items that have a parent-child relationship. )

Editing a Constraint

You can create a Time Buffer (also commonly referred to as slack or lag and lead time) between the completion of 
one activity and the start of a successor by editing the constraint. 

To add a time buffer to a constraint, 

1 Click in the graphics pane on the blue line representing the dependency between two activities.

2 Click the Edit Constraint button . 

3 In the Edit Constraint dialog box that appears, enter the number of days of slack time you want, or modify the 
existing value as desired. 

The value you enter appears in the Time Buffer field on the object’s Dependencies tab. 

A lag or lead can also be entered in the Web Client.  When you next open the Gantt Chart you need to select Edit > 
Reschedule to change the dependent activity's start date based on the lag or lead time.

Resource View
Click the Resource button at the bottom to open the Resource view. This view provides a listing of all resources used 
in the activities, and their task loading. 

❑ If you rest the mouse pointer over the utilization graph in the lower part of the graphics pane, a tool tip appears 
showing you the resource name and utilization information. 

❑ You can select one or more resources in the field pane on the left and view the resource loading in the lower 
graphics window. 
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Other options
❑ Use the LookAndFeel menu to change the overall appearance of the Gantt chart window. The choices are Metal, 

CDE/Motif, and Windows.

❑ The Label By menu lets you change the labeling on each bar of the bar graphs. 

❑ The Grids menu lets you customize the display grids. 
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APPENDIX A
Eigner PLM 5.1 Integration

This appendix discusses the integration of Agile with an Eigner PLM 5.1 system. The subjects discussed 
include:
❑ Adding Eigner Objects as Deliverables
❑ Modifying the Trigger Event and Result
❑ Updating a Program to Eigner PLM
❑ Modifying Objects in Eigner PLM
❑ Other Information

Objects in Eigner PLM can be added to Agile PE activities and gates as deliverables. This capability enables a change 
of state in an Eigner object to trigger a change in workflow status of an Agile object. You can also copy Agile programs 
to Eigner as new projects, duplicate deliverables into Eigner, and launch the Eigner object in the Eigner web client 
directly from Agile PE. 

Note To use Eigner PLM objects, several configuration steps are required. The details are found in an appendix 
to the Agile 9 Installation Guide. 

Adding Eigner Objects as Deliverables
Once the Eigner PLM connection has been established, you can add Eigner objects as deliverables to a PE activity 
such as a program or task. 

To add Eigner objects to a PE activity:

1 Go to the Deliverables tab of a PE object. 

2 Click the Add button

3 In the Add Related Content wizard, use the search options under Search From Existing Eigner Entities to locate the objects 
you want. Or you can choose Create New Object to create a new Eigner object. In the search results, select all 
objects you want to add as deliverables.

4 In the Information wizard step, specify the Event and Result, if desired. 

Event is a target status in the Eigner deliverable, and Result is a resulting change of the Agile object’s workflow status 
triggered by the status change of the Eigner deliverable. The trigger of the Agile program object occurs when the 
current Eigner object status is greater than or equal to the Event status.

5 Click Add More if you want to add other Eigner objects, or click Finish. 
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Modifying the Trigger Event and Result
Once the Eigner entity has been added, the status-change trigger and result can be changed by selecting the object 
on the Deliverables tab and clicking Edit. 

To change the trigger event and result:

1 Go to the Deliverables tab of the activity.

2 Check one or more deliverables you want to modify. Click Edit.

3 For each object, select the triggering event in the Event dropdown list, and select the resulting workflow status in 
the Result dropdown list.

4 Click the Save button to save the changes in Agile PE. 

Updating a Program to Eigner PLM
Once you have created a program in PE, you can send the program structure, deliverables, links and roles on the 
Team tab to the Eigner PLM system as a new Eigner project. 

You can choose to copy this PE program structure at any level into Eigner.  A flag is set at each Agile object to indicate 
whether or not it will be updated to Eigner.

Users that have access to the program in PE are given access to the corresponding objects in Eigner through a role 
mapping that is set up by the administrator. Refer to the appendix to the Agile 9 Installation Guide for further detail 
and configuration.

To update the Eigner database with an Agile program:

1 Open the program. 

2 Verify that the Update to Eigner field on the General Info tab is set to Yes for all levels of the hierarchy that you want 
to copy into Eigner as Eigner project objects. If it is not, click the Edit button, and set the field to Yes. 

3 From the Actions menu, choose Update Program to Eigner. 

4 Select the Eigner project that you want to copy the PE program into.  The new Eigner project will be placed within 
the selected project. 

5 Select options to copy the deliverables, links, and roles of team members to Eigner. 

You now can view the new project in Eigner. You can select the In Projects tab within the Eigner web client to see the 
higher level project that was selected.

Within Agile PE, the root level program will now appear on the Links tab, enabling you to navigate directly to this 
project in Eigner.

Modifying Objects in Eigner PLM
Eigner objects that appear on the Deliverables tab can be modified in the Eigner web client.  

To modify an Eigner object on the Deliverables tab:

Click the object name in the Deliverables table. 

You will see a page that says “Connecting to Eigner PLM.” Then the object opens in the Eigner web client, without 
the need for a separate login. If a change is made to the status of the object in Eigner to promote it to its event or 
target status, then the activity in Agile PE will be updated upon refreshing.

For information about modifying the object, refer to the Eigner PLM web client documentation. 
A-2 Program Execution User Guide



Appendix A Eigner PLM 5.1 Integration
Other Information
Some other information about the integration between Agile PE and Eigner PLM:

❑ A new user or user group added to the Eigner system is updated to Agile PE periodically. These users/user groups 
are not available for adding as resources in PE. Users in Eigner that have person information, including first 
name, last name, and email, are automatically copied to the Agile PE user list.

❑ User Groups that have an owner and department are automatically populated as Resource Pools within Agile PE. 
The manager attribute specifies the owner of the resource pool in PE.

❑ When new entities, new roles, or new auto-numbers are created in Eigner PLM, they can be used in Agile PE, 
provided the configuration steps in the appendix to the Agile 9 Installation Guide have been followed. The new 
roles created in Eigner can be mapped with the Agile roles. The are used only to create job functions in Eigner. 
The autonumbers created in Eigner can be used for creation of Eigner objects from Agile.

❑ You can create an Eigner work order directly from Agile. (Special configuration is required; see Appendix A of 
the Agile 9 Installation Guide.) 
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